Hello welcome to Yzone.net

vim安装自动补全插件YouCompleteMe

安装准备

  • 最新版的Vim(7.4+)
  • cmake(mac可以通过homebrew安装,brew install cmake,ubuntu可以通过sudo apt-get install cmake)
  • 安装vundle插件,用于安装管理vim的插件. 并按照Readme设置好。

快速安装

~/.vimrc中添加下列代码

Plugin 'Valloric/YouCompleteMe'

保存退出后打开vim,在正常模式下输入

:PluginInstall

等待vundle将YouCompleteMe安装完成

而后进行编译安装:

cd ~/.vim/bundle/YouCompleteMe
./install.py --clang-completer
# 可直接使用参数 --all 加上所有的补全,包括(c/c++ go c# php等)
./install.py --all 
  • 可使用 ./install.py --help 查看支持哪些补全
  • 如果不需要c-family的补全,可以去掉--clang-completer。如果需要c#的补全,请加上--omnisharp-completer
  • 可直接使用参数--all 加上所有的补全,包括(c/c++ go c# php等)

若提示需要安装YouCompleteMe子模块,需要运行

git submodule update --init --recursive

然后在执行安装命令 ./install.py [options]


分类 vim    标签 vim , tool
文档结构