Hello welcome to Yzone.net

centos 7安装wizNote(为知笔记)

centos 7安装wizNote(为知笔记)

$ yum install yum-plugin-copr 
$ yum copr enable mosquito/wiznote
$ yum install wiznote     # Stable version  
// Or
$ yum install wiznote-beta    # Development version

如果无法安装yum-plugin-copr, 你需要添加仓库地址 repo info 到你的仓库列表文件中 /etc/yum.repos.d/epel.repo, 或者直接下载仓库配置文件到仓库存放目录 /etc/yum.repos.d/.

下面是下载/安装代码:

$ cd /etc/yum.repos.d/
$ sudo wget https://copr.fedorainfracloud.org/coprs/mosquito/wiznote/repo/epel-7/mosquito-wiznote-epel-7.repo
$ sudo yum install wiznote

若出现依赖无法满足的错误,如:

正在解决依赖关系
--> 正在检查事务
---> 软件包 wiznote.x86_64.0.2.3.1-1.gitfdd16c9.el7.centos 将被 安装
--> 正在处理依赖关系 libQt5Concurrent.so.5()(64bit),它被软件包 wiznote-2.3.1-1.gitfdd16c9.el7.centos.x86_64 需要
--> 正在处理依赖关系 libQt5Core.so.5()(64bit),它被软件包 wiznote-2.3.1-1.gitfdd16c9.el7.centos.x86_64 需要
--> 正在处理依赖关系 libQt5Gui.so.5()(64bit),它被软件包 wiznote-2.3.1-1.gitfdd16c9.el7.centos.x86_64 需要
... ...

需要安装epel源,可以用阿里云的 help-epel,再 sudo yum update更新后,执行上面的命令

来自 wiznote github


分类 linux    标签 centos 7 , wiznote
文档结构